카테고리: Opensources

오픈소스 관련 뉴스와 소개자료 스터디

Mac OS – KoNLPy 설치하기

KoNLPy 설치하기 – 맥 OS KoNLPy 설치 중 gcc 관련 오류 발생시 (아마도 Mac 에서는 십중팔구 오류가 발생할텐데), gcc 의 stdlib 를 libc++ 로 변경하여 다시 수행한다. 관련 이슈 : Mac OS konlpy 설치오류 설치를 완료하면 python 콘솔을 띄워 간단히 테스트를 수행해 본다. (Twitter 말뭉치 사용) 이번에는 MeCab 말뭉치를 이용해 테스트를 해 보자. (앞에 선택사항 ...

How to make Logstash filter plugin with Java

Logstash 의 java 필터 개발하기 ** 참고문서https://www.elastic.co/guide/en/logstash/7.2/java-filter-plugin.html 1) logstash 다운로드 및 logstash-core 라이브러리 빌드 – logstash 의 plugin 들은 logstash-core 의 API 를 이용하기 때문에 미리 빌드해야 한다– 최신 plugin 들은 rubyUtils.gradle 파일이 필요하다. 이 버전은 logstash v7.2 부터 존재함 2) logstash filter java example 다운로드 및 빌드 3) logstash_plugin install 및 테스트 Java code ...

s

spring shell sample (REPL)

We are using Spring shell, and it worked really well for us. Some of its features: A simple, annotation driven, programming model to contribute custom commands Use of Spring’s classpath scanning functionality asthe basis for acommand plugin strategy and command develoment Inheritance of the Roo Shell features, most notably tab completion, colorization, and script execution. Customization ...

How to install sqlg on Tinkerpop

https://github.com/blazegraph/tinkerpop3/issues/4#issuecomment-281932805 https://github.com/blazegraph/tinkerpop3/issues/4#issuecomment-281932805

How to install zombodb on CentOS 6

ZomboDB [github] Prerequisites Postgres 10.x installed libcurl >= 7.28.0 installed <== important A 64bit Intel Architecture Install PG-10 Download libcurl source (current version 7.64.0)https://curl.haxx.se/download.html ** NOTE:You cannot install libcurl by binary version on CentOS 6.x. I had tried. Install libcurl by source start elasticsearch servicecreate extension zombodb; Test zombodb ** Reply From zombodb [twitter] Getting ...

AWS EC2에 Node 6.x 설치하기

AWS EC2에서는 Node 설치에 4.x 버전만 제공하고 있다. 이를 무시하고 6.x대의 최신 Node를 설치하기 위해서는 ‘source install’ 을 할 수 밖에 없다. EC2에서는 ‘nodejs.x86_64’ 패키지에 대해 4.7.2만 지원하고 있다. Node 6.x 소스를 다운받아 설치해 보자. * 다운로드: https://nodejs.org/ko/download/ 정상적으로 설치가 된 것 같지만, sudo 접두어를 붙이면 실행이 되지 않는다. $ sudo npm install -g typescript sudo: ...

vim 설정하기 (typescript Highlighting)

vi 에디터는 linux 계열을 다루기 위해서 필수적으로 사용하는 에디터다. 텍스트가 이쁘게 출력되면 당연히 개발생산성이 향상된다. 사용자 계정의 vi 설정을 하기 위해서는 ‘~/.vimrc’ 를 편집하면 된다. 설정의 내용은 다음 문서를 참조했다. * 출처: vim 에디터 이쁘게 사용하기 여기서 colorscheme는 에디터의 스타일을 말하는데, jellybeans 스타일은 기본 셋팅에는 설치되어 있지 않아 다운을 받아야 한다. * 출처 : https://github.com/nanotech/jellybeans.vim 설치하는 ...